Using MacOS - Bootstrapping project failing


(Prathik Kulkarni) #1

I am getting below error when I run docker-compose up --detach
Step 9/15 : RUN apt-get install -y oracle-java8-installer

—> Running in ad3920b0c0de

Reading package lists…

Building dependency tree…

Reading state information…

Package oracle-java8-installer is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

E: Package ‘oracle-java8-installer’ has no installation candidate

ERROR: Service ‘iofog-connector’ failed to build: The command ‘/bin/sh -c apt-get install -y oracle-java8-installer’ returned a non-zero code: 100


(Serge Radinovich) #2

We have a fix we will push up soon. Which branch of demo repo are you using?


(Karthik Nujella) #3

I am getting the same error on Ubuntu 18.04 as well!!

@SergeRadinovich, Could you please help me with this!

Thanks!


(Serge Radinovich) #4

This should now be fixed.


(Karthik Nujella) #5

Great! This is working!! Thank you :slight_smile: