Ssh error cannot decode


#1

Hello
I followed the preparation tutorial for deploying on a remote host, I tried to deploy a controller on a raspberrypi but every time I output:
` ✘ ssh: cannot decode encrypted private keys `

I have successfully generated and copied the public key on the remote host and the data on the .yaml file are correct for both user, host and path of the key.

thinking it was a version problem I tried both with 1.2.5 and with 1.3.0 but the problem continues to exist

Could someone help me solve this problem?

Thanks in advance


#2

I think I might know what is going on here. Do you have a password on your ssh key? We have seen issues where users have a password protected ssh key (which is not usually a problem if you are manually connecting to a server via ssh, but is a problem if you want to do unattended ssh).

If so, please regenerate a key without a password and use that.

Thanks


(Serge Radinovich) #3

iofogctl doesn’t support password encrypted SSH keys. As drluckyspin mentioned. Thanks