Size mismatch error while setting up tutorial images

docker
docker-compose

(Karthikpanicker) #1

While trying to setup the containers using docker-compose on Macos 10.14.1, I encountered the following error.

Step 13/17 : RUN sudo apt-get install iofog-agent
_ —> Running in 4cb9cbcd28a3_
Reading package lists…
Building dependency tree…
Reading state information…
The following NEW packages will be installed:
_ iofog-agent_
0 upgraded, 1 newly installed, 0 to remove and 34 not upgraded.
Need to get 20.6 MB of archives.
After this operation, 22.9 MB of additional disk space will be used.
Get:1 https://packagecloud.io/iofog/iofog-agent/ubuntu/ trusty/main iofog-agent all 1.0.2 [20.6 MB]
Fetched 20.6 MB in 10s (1896 kB/s)
E: Failed to fetch https://packagecloud.io/iofog/iofog-agent/ubuntu/pool/trusty/main/i/iofog-agent/iofog-agent_1.0.2_all.deb Size mismatch

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
ERROR: Service ‘iofog-agent-1’ failed to build: The command ‘/bin/sh -c sudo apt-get install iofog-agent’ returned a non-zero code: 100

Docker version - Docker version 18.09.0, build 4d60db4
Compose version - docker-compose version 1.23.2, build 1110ad01


(Karthikpanicker) #2

Deleted all docker containers and images installed in the system and tried running docker-compose again. This seems to have resolved the issue. I had tried quickstart 3-4 weeks back and had few images pulled from the repository then.


(Kilton Hopkins) #3

Hi - I’m glad you were able to resolve it!

We have been making improvements, but that also means that older cached versions of the demo containers can potentially cause issues. Looks like that’s what you ran into. I’m glad you posted the solution here.

If anyone else runs into similar issues, please try this technique and you can also use this command if needed to clear older microservice containers:

docker-compose down --rmi all