Quickstart instructions failing: Step 14/23 : COPY id_ecdsa.pub /


(Jefferyanderson) #1

When I run through the quickstart guide, I run into issues when attempting to do the docker-compose up --detach step:

iofog$ docker-compose up --detach
Building iofog-agent
Step 14/23 : COPY id_ecdsa.pub /
ERROR: Service 'iofog-agent' failed to build: COPY failed: stat /var/lib/docker/tmp/docker-builder634444583/id_ecdsa.pub: no such file or directory

Any suggestions?


(Luboš Krčál) #2

@jefferyanderson

The quickstart guide and the corresponding archive were unfortunately outdated and did not correspond to the latest state of our Demo package.

We have published an updated quickstart guide and a new Demo package.

Please let us know if there are any further issues with the new quickstart documentation and package.

Thank you.


(Jefferyanderson) #3

Thanks for the updates. For what it’s worth, the step where you define your self-generated certificate and key has errors too - easy enough to figure out, but the example is not consistent.

Also:
in this step, there’s an error:
iofog-controller iofog provisioning-key --node-id

it’s actually:
iofog-controller iofog provisioning-key --iofog-uuid

On the agent, the example shows adding an IP address, but this needs to be modified to include http://
The example should use the default port, too.

And finally, I’m stuck because provisioning on the agent fails with this error:

iofog-agent provision —
Provisioning with key “—” … Result: Provision failed with error message: “Unexpected character ‘<’ (Codepoint: 60) on [lineNumber=1, columnNumber=2, streamOffset=1]. Reason is [[Expected structural character or digit or ‘t’ or ‘n’ or ‘f’ or ‘-’]]”

*key omitted, but I’m using the 8 character key provided by the command:
iofog-controller iofog provisioning-key --iofog-uuid


(Luboš Krčál) #4

Sorry for the rest of the documentation being outdated and thank you for pointing out these inconsistencies.

As for the command iofog-controller iofog provisioning-key --iofog-uuid, are you running the setup manually? If so, please provide all the steps that lead you to the error and we will try to investigate further.

You should be able to use the demo package that we posted previously using the provided scripts. There should be no need to do the provisioning manually. Try the following:

$ cd where/we/want/iofog-demo
$ curl -L -o demo.tar.gz https://github.com/eclipse-iofog/demo/archive/v1.0.0.tar.gz
$ tar -zxvf demo.tar.gz --strip-components=1
$ ./start.sh

If the key generation or copy step fails again, please post the whole logs.