Microservice taking too long to get to RUNNING state

microservices

(Ivan Cilic) #1

Hi, is there any way to reduce time to get microservice running? I have a service which need less than a second to start using “docker run” command, but using ioFog it takes around 20 seconds to get it running. I have a dynamic serverless system so it is important to have the startup time as short as possible. I tried reducing “get_changes_freq” but it still remains long. Looking at the agent logs I can see that it takes less than 2 seconds between “starting container” and “status: running” logs so I guess controller needs a lot of time to process the request to deploy microservice or my agent is not pulling messages very often.


(Serge Radinovich) #2

Hi @cilicivan96 sorry again for the slow response.

I have recreated the issue you are experiencing. I tried modifying a few frequencies to reduce the delay but this did not help.

At this point its an issue/bug we will backlog and look at when we have an opportunity. You are also welcome to create an issue in the Agent repo: https://github.com/eclipse-iofog/Agent/issues.

You are also super welcome to create a PR fixing the issue if you feel like digging into Agent!

Thanks