Issues with Controller Catalog in Tutorial

catalog
iofog-controller

(jono) #1

I’m currently working through the tutorial and I’m having some issues deploying the Moving Average microservice. I add the catalog item successfully or at least I get a success msg when I add it.

iofog-controller catalog add
–name “Moving Average”
–x86-image jonoberg/moving-average:v1
–registry-id 2
–user-id 1

{“name”:“Moving Average”,“registryId”:2,“images”:[{“containerImage”:“jonoberg/moving-average:v1”,“fogTypeId”:1}]}
{“id”:18}
Catalog item has been created successfully.

But when I run iofog-controller catalog list, I don’t see it anywhere in the json that is returned or when I run iofog-controller catalog info -I 18, I receive the following error:

{“itemId”:18}
Invalid catalog item id 18

Any thoughts?


#2

There’s a bug with catalog item’s category which will be fixed in the next release.

For now you just need to add some category to your catalog item and it should work.
You can update your existing catalog item using

iofog-controller catalog update -i 18 --category "someCategory" --registry-id 2

and then it’ll be both visible in the list & info commands.

This issue is similar to Error adding microservice


(jono) #3

Perfect. That seemed to solve it.